Welcome to PColP Software Client for macOS

Welcome to PColP Software Client for macOS

Welcome to the Teradici PColP® Software Client for macOS Administrators' Guide.

PColP Software Clients are applications that establish PColP sessions with remote Windows or
Linux desktops. Connections can be made remote desktops and workstations via either PColP
Agents (component of Cloud Access Software) or Remote Workstation Cards.

This guide explains how to install, configure, and use the PColP Software Client for macOS. It
includes client system requirements and information on host dependencies.
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Who Should Read This Guide?

Who Should Read This Guide?

This guide is intended for administrators and users who install, configure, or use the Teradici
PColP® Software Client for macOS.

/" Understanding terms and conventions in Teradici guides

For more information on the industry specific terms, abbreviations, text converntions, and graphic symbols used in
this guide, see Using Teradici Product and Component Guides and the Teradici Glossary.
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What's New in This Release

What's New in This Release

The PColP Software Client for macOS 21.01 introduces the following features and enhancements:

Launch PColP Software Client with a URI

The PColP Software Client can be launched from a webpage using a URI with additional
parameters specified. For more information on this, see here.

Custom Logo Configuration

The PColP Software Client can be configured to place a custom logo beside the PColP logo. For

more information on this, see here.

Local Termination for Wacom Tablets support added to the PColP Software
Client for macOS

The PColP Software Client for macOS now supports local termination of Wacom Tablets. For
information on the models supported, see here.

Support for macOS Big Sur (11.0) Added

macOS Big Sur (11.0) is now supported with the PColP Software Client for macOS. USB redirection
is not currently available for macOS Big Sur (11.0).

Support for Apple M1 Macs Added

Apple M1 Macs are now supported with the PColP Software Client for macOS. This processor
does not support USB or PColP Ultra.
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Strict PColP Software Client Parameter Parsing

Strict PColP Software Client Parameter Parsing

The parsing of the PColP Client parameters is more restrictive in this release. If the parameters are
not properly formatted the PColP Client will exit. For more information on the PColP Client
parameters, see here.

Security and Stability Updates

Increased security and stability updates and enhancements around the PColP Client.
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Additional Documentation

Additional Documentation

The following guides contain additional information relevant to PColP systems and PColP
Software Clients:

+ For more information about Teradici Cloud Access Software, including detailed information on
included PColP components as well as Teradici All Access plans, see the Teradici Cloud
Access Architecture Guide.

+ For more information about Teradici PColP agents, which are required on remote virtual
machines, see the following pages:

o Teradici PColP Standard Agent for Windows
o Teradici PColP Graphics Agent for Windows
o Teradici PColP Standard Agent for Linux
o Teradici PColP Graphics Agent for Linux

+ For information about Teradici PColP Host Software, which is required on remote
workstations using a Teradici PColP Remote Workstation Card, see the following pages:

o PColP Host Software for Windows

o PColP Host Software for Linux
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System Requirements

System Requirements

The following table outlines the system requirements for the PColP Software Client for macOS:

System Version Required

PColP Software Client Operating Systems
+ macOS Catalina (10.15)

+ macOS Mojave (10.14)

+ macOS Big Sur (11.0) This OS does not
support connecting USB devices to a remote
desktop.

+ Apple M1 Hardware This processor does not
support USB or PColP Ultra

Compatible PColP agents All PColP agents and versions should work.
Teradici recommends using the same version of
PColP Agent as PColP Client.

Compatible PColP Remote Workstation Cards TERA22x0 with firmware 5.0.1+.

Customers may still connect to a non-brokered PColP Remote
Workstation Card by connecting to the FQDN of the
workstation instead of the PColP Remote Workstation Card.

Compatible PColP Host Software*
+ Remote Workstation Card Software for

Windows: 20.04

+ Remote Workstation Card Software for
Linux: 20.04

IPv Support IPv4 supported

*Only required when connecting to PColP Remote Workstation Cards.
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Hardware System Requirements

Hardware System Requirements

For different display configurations Teradici recommends certain processor and RAM

combinations:

6 Remote Workstation Platforms

PColP Host Software must be installed on Remote Workstation machines to enable keyboard and mouse

functionality.
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Audio Support

Audio Support

Stereo audio output and mono audio input are supported and enabled by default.

On MacOS Catalina 10.15 configuration is required to enable microphone access on the PColP
Client. For information on the steps to do this, see here.

The PColP Client provides an enhanced audio and video synchronization (A/V Sync) feature that
provides improved full-screen video playback, reducing the difference in delays between the audio
and video channels and smoothing frame playback on the client. This improves lip sync and
reduces video frame drops for movie playback. This feature introduces a small lag in user
interaction responsiveness when enabled. Using enhanced audio and video synchronization will
reduce the maximum frame rate.

For more information on the A/V Sync feature, see Enhanced Audio and Video Synchronization.
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Displays

Displays
The PColP Client supports a maximum of four displays and a maximum resolution of 4K UHD

(3840x2160).

Monitors can be arranged in a vertical line, a horizontal line, or as a 2x2 box display. They can be
used in any standard rotation (0°, 90°, 180°, or 270°), with any monitor as the primary display.

/" Note: Using multiple high-resolution displays

Systems with multiple high-resolution displays, such as quad 4K UHD topologies, require powerful system
infrastructure. Be sure to use a system with sufficient bandwidth and client capability to support your required display
topology.

6 Important: Attaching monitors to the host machine in not supported

PColP client supports a maximum of four displays. Attaching extra monitors to the host machine will conflict with
client display topologies.
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Supported Languages

Supported Languages

The PColP Client supports the following languages:

+ French

+ German

+ Spanish

+ Simplified Chinese
« Traditional Chinese
+ Japanese

* Portuguese

+ Italian

+ Korean

* Russian

+ Turkish

© 2021 Teradici

10



PColP Ultra

PColP Ultra

The PColP Client provides support for PColP Ultra, the latest protocol enhancements from
Teradici. PColP Ultra is optimized for truly lossless support with bit-exact color accuracy and
preservation of content detail at the highest frame rates.

PColP Ultra protocol enhancements propels our industry-recognized performance into the future
of remote computing, with faster, more interactive experience for users of remote workstations
working with high-resolution content.

PColP Ultra enhancements are controlled on the PColP Agent. There is no configuration required
on the PColP Client.

; PColP Ultra is appropriate for specific use cases

For most users, the default PColP protocol will provide the best possible experience. Carefully review the
recommended use cases in the next section to determine whether you should enable it.

When to Enable PColP Ultra

In release 20.01, PColP Ultra supports the following use cases:

+ Users requiring CPU-optimized delivery of 4K UHD, high-framerate video playback.

- Efficient scaling across multicore CPUs, leveraging AVX2 instruction sets.

For all other scenarios, Teradici recommends that you leave PColP Ultra disabled. For additional
detail on PColP Ultra technical requirements for various use cases and troubleshooting steps, refer
to KB 2109: PColP Ultra Troubleshooting.

Requirements

To take advantage of PColP Ultra, you need:

- A PColP Agent (any type), 19.11 or later

© 2021 Teradici

11


https://help.teradici.com/s/article/2109

Enabling PColP Ultra

- A PColP Software Client (any type), 19.11 or later

+ The CPUs on both the agent and the client machines must support the AVX2 instruction set.

Enabling PColP Ultra

In order to enable PColP Ultra features you need to turn on GPO variables in the PColP Agent. For
information on enabling this with Linux, see Enabling PColP Ultra for Linux. For information on
enabling this with Windows, see Enabling PColP Ultra for Windows.

PColP Codec Indicator

When enabling PColP Ultra there will be an onscreen indicator at the bottom left corner of the
screen. PColP Ultra CPU optimization is indicated with a dark blue dot. PColP Ultra GPU
optimization is indicated by a magenta dot. To disable this codec update the
pcoip.code_indicator parameter:

~/.pcoip.rc pcoip.codec_indicator = 0

© 2021 Teradici
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Printing Support

Printing Support

When a local printer is visible to a client computer by USB connection or local network connection,
it may be possible to print from the host machine. Refer to the following table for local printing
support.

The following are the printing options available with the PColP Client:

+ Local USB Printing: Printing to a USB printer locally attached to the Client device.

- Remote Network Printing: Enables printing to a network printer on the nost machines
network. Not suitable in situations here the PColP Software Client device is not on the same
network as he host device.

+ Cloud Printing: This is access to external Cloud Services that are set-up on your local
workstation and network. Once these services have been correctly configured they can be
used by the PColP Software Client.

+ Local Network Printing: Enables printing from the host machine to a printer in the PColP
Client machine's local area network. This method is suitable for printing when host and client
are not on the same network or for identifying and printing to local printers that exist in multi-
site organizations.

PColP Agent for Windows PColP Agent for Linux

Local USB Printing v -
printer is connected to a USB port on the client computer

Remote Network Printing v -
Local Network Printing v —

Cloud Printing v —

The PColP Standard Agent for Linux does not support local printing on remote clients.

© 2021 Teradici
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Printing Support

Local, network, and cloud printers are supported in various ways:

+ Linux hosts can print to any printer on the host machine’s local area network.

- If your host host workstation has access to the Internet, cloud-based printing is supported
through cloud-printing services such as Google Cloud Print and HP Mobile Printing.

© 2021 Teradici
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USB Support

USB Support

PColP Clients supports redirecting USB devices to a remote session. Administrators can set rules
governing allowed and disallowed devices, device classes, or device protocols.

a Important: USB support is enabled by default

USB bridging is enabled by default. If you want to restrict or disable USB support, you can globally disable or set rules
governing USB behavior via GPO settings on the PColP Agent.

Remote USB Device Support

If a pointer type USB device, for example wacom tablets, mouse, or stylus device, is remoted, you
need to grant PColPClient.app computer control to enable it to rendor and move the cursor. You
can enable this through the Preferences>Security & Privacy>Privacy>Accessibility location on

your system settings.

Isochronous USB device Support

USB devices with time-sensitive information, such as webcames, are not generally supported.
However, Teradici's technology partners provide additional solutions to expand peripheral support
such as webcams. For more information, look for partners listed under Peripherals on the Teradici
Technology Partners page.

USB Device Pressure Sensitivity

The PColP Software Client for macOS may encounter issues with Wacom pressure sensitivity.
This is as a USB handling restriction on macOS Catalina. It occurs when you want to load the USB
Kernel Extension at session start up. For information on how to address this issue, see here.
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Wacom Tablet Support

Wacom Tablet Support

The Software Client for macOS supports Wacom tablets in two configurations: bridged, where
peripheral data is sent to the desktop for processing, and locally terminated, where peripheral data
is processed locally at the Software Client.

Locally terminated Wacom tablets are much more responsive and tolerate low latency
connections.

Whether the Wacom tablet is locally terminated or bridged, the process of remoting the USB
device is the same, you need to click connect in the USB menu or auto forward the device. If local
termination is supported for the particular device, it will automatically be chosen over bridging. For
more information on this, see Local Termination Blacklist.

Remote USB Device Support

If a pointer type USB device, for example wacom tablets, mouse, or stylus device, is remoted, you
need to grant PColPClient.app computer control to enable it to rendor and move the cursor. You
can enable this through the Preferences>Security & Privacy>Privacy>Accessibility location on
your system settings.

Locally Terminated Wacom Tablets

Locally-terminated tablets have greatly improved responsiveness, and tolerate higher-latency
(including 25ms and higher) networks.

Local termination requires:

+ A Standard agent or Graphics agent for Windows version 21.01 or higher.

-+ A Standard agent or Graphics agent for Linux version 21.01 or higher.
The following Wacom tablet models have been tested and are supported with local termination.

PColP client support for locally terminated Wacom tablets and the Software Client for macOS

© 2021 Teradici
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Locally Terminated Wacom Tablets

PColP PColP PColP PColP PColP Remote
Standard Graphics Standard Graphics Workstation

Agent for Agent for Agent for Agent for Card

Linux Linux Windows Windows

Intuos Pro Small v v v v —
PTH-460

Intuos Pro Medium v v v v -
PTH-660

Intuos Pro Large v v v v -
PTH-860

Cintiq 22HD - - - - -
DTK-2200

Cintiqg Pro 24 - v v v v -
Pen Only
DTK-2420

Cintig 22 v v v v -
DTK-2260

Cintiq 22HDT - - — — — _
Pen & Touch
DTH-2200

Cintiq Pro 24 - - — — — _
Pen & Touch
DTH-2420

Cintiq Pro 32 - v v v v -
Pen & Touch
DTH3220
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Bridged Wacom Tablets

Bridged Wacom Tablets

Bridged Wacom tablets are supported only in low-latency environments. Tablets in network
environments with greater than 25ms latency will show reduced responsiveness and are not
recommended.

The following Wacom tablet models have been tested and are supported on a PColP Software
Client for Mac.

PColP client support for bridged Wacom tablets and the Software Client for Mac

PColP PColP PColP PColP PColP Remote
Standard Graphics Standard Graphics Workstation

Agent for Agent for Agent for Agent for Card
Linux Linux Windows Windows

Intuos Pro Small v v v v —
PTH-460

Intuos Pro Medium v v v v —
PTH-660

Intuos Pro Large v v v v -
PTH-860

Cintiq 22HD v v v v -
DTK-2200

Cintiq Pro 24 - v v v v -
Pen Only
DTK-2420

Cintiq 22HDT - v v v v —
Pen & Touch
DTH-2200

Cintiqg Pro 24 - v v v v -
Pen & Touch
DTH-2420

© 2021 Teradici
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Known Issues with Wacom Tablets and Functionality

PColP PColP PColP PColP PColP Remote
Standard Graphics Standard Graphics Workstation

Agent for Agent for Agent for Agent for Card
Linux Linux Windows Windows

Cintiq Pro 32 - v v v v -
Pen & Touch
DTH3220

Known Issues with Wacom Tablets and Functionality

Whilst testing and developing the compatibility of Teradici Cloud Access Software with different
Wacom tablets, certain performance issues arise. The following is a list of the current known
issues with certain Wacom tablets:

+ The touch feature does not work on any supported device for both bridged and locally
terminated devices across all platforms.

- ExpressKey Remote does not work on the Wacom Cintig Pro 32 (DTH-3220). You should still
remote to this device when remoting to the Wacom tablet.

+ There are cursor limitations when working with the Wacom Cintiq 22HD (DTK-2200) and
Wacom Cintig Pro 24 (DTK-2420) for both bridged and locally terminated devices across all
platforms.

- There is a issue with the control buttons on the Wacom Cintiq Pro 32 (DTH-3220) device. The
buttons do not function on locally terminated devices across all platforms.

+ PColP Clients are not compatible with NoMachine and No Machine USB drivers. For
information on how to uninstall NoMachine USB drivers, see here.

/" Cintiq 22HD Wacom Driver

The Cintig 22HD may require the Wacom driver to be installed on both the PColP Agent and PColP Client. The driver
version on the PColP Agent must be 6.3.32-4. The driver on the PColP Client must be the latest version available.
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USB Device Pressure Sensitivity

USB Device Pressure Sensitivity

The PColP Software Client for macOS may encounter issues with Wacom pressure sensitivity.
This is as a USB handling restriction on macOS Catalina. It occurs when you want to load the USB
Kernel Extension at session start up. For information on how to address this issue, see here.

Wacom Cintig Pro 32 Tablet Selection

The Wacom Cintig Pro 32 shows up as multiple devices in the USB menu. You should remote the
following USB devices as outlined in the image below to remote to this Wacom tablet:

+ ExpressKey Remote

+ Cintig Pro 32 Touch

+ Wacom Cintig Pro 32

e
7 USB Devices X

DEVICES =
ExpressKey Remote Disconnect |
Cintig Pro 32 Touch Disconnect |
Wacom Cintig Pro 32 Disconnect |
USB3 Reader Connect |
Single RS232-HS Connect | ]
USB Advanced Audio Device Connect | _l

v

[¥ Show Human Interface Devices. Devices that are auto-forwarded are not affected by this checkbox.

Close

© 2021 Teradici 20



Installing the PColP Software Client for macOS

Installing the PColP Software Client for macOS

In this section, you'll learn how to install and uninstall the PColP Software Client for macOS.

Before You Begin

Before installing a PColP Software Client:

+ You must be logged in as an administrator to the client machine.

+ Close any existing PColP Software Client applications.

Installing the PColP Software Client

To install the PColP Software Client:

1. Copy the PColP Software Client disk image file PColPClient.dmg to your desktop.
Double-click the file to mount the volume.

Accept the license agreement by clicking Agree.

> W™

In the PColPClient volume window, drag the PColPClient icon into the Applications folder icon
to install the program.

_| PColPClient
A
Applications PColPClient.app

5. To optionally create an alias on the desktop or the dock:

+ Double-click the Applications folder icon to open the folder.

© 2021 Teradici
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To uninstall the PColP Software Client:

+ Drag the client application to the desktop or dock.

6. To eject the volume when you are finished, drag it to the trash.

To uninstall the PColP Software Client:

- Navigate to the Applications folder and drag the PColPClient program to the trash. Or, right-
click the application and select Move to Trash.

© 2021 Teradici
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Using the PColP Software Client

Using the PColP Software Client

After installing a PColP Software Client on your client machine, you can connect to the following
PColP solutions or products or hosts:

+ Teradici PColP Graphics Agent or PColP Standard Agent installed as part of Teradici Cloud
Access Software.

+ Teradici PColP Remote Workstation Card and Teradici PColP Host Software installed in a
Windows or Linux workstation.

+ If you want to connect to the PColP Remote Workstation Card you need to install the PColP
Remote Workstation Card Agent along with PColP Host Software.

© 2021 Teradici
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Connecting to Virtual Machines

Connecting to Virtual Machines

You can connect to virtual Windows or Linux hosts that have a PColP Standard Agent or PColP
Graphics Agent installed. Connections can be made directly to individual host machines, or via a

connection broker in managed deployments.

To connect to a remote workstation or virtual desktop:

1. Double-click the PColP Client desktop icon, alias, or program file PColPClient to launch the
application.

2. In the Host Address or Code field, enter one of the following:
- For direct connections, provide the address of the host machine.

- For managed connections, provide the address of the connection manager.

If you want to save this connection later for easy recall, enter a name in the Connection Name
fleld. You will save the connection in step 5.

3. Click NEXT.

© 2021 Teradici
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To connect to a remote workstation or virtual desktop:

4. On the next screen, select your domain from the dropdown list, enter your user name and
password for the desktop, and then click LOGIN.

© About the Security Padlock Indicator

The login screen displays a red padlock indicator when accessing a PColP agent desktop that uses default self-
signed certificates. The icon indicates that the software’s certificate is not signed by a trusted certificate

If the client trusts your internal CA, a green padlock icon displays on the screen instead. To learn more about
certificates, see the PColP agent administrators guides listed in the Teradici Cloud Access Architecture Guide.

© 2021 Teradici
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To connect to a remote workstation or virtual desktop:

5. If your login is successful, the following screen appears with a list of available desktops:
@ C Teradici PColP Client

= TERVDILIND62 [Ready] o) a TERVDIW10P3 [In Session] ol

a vwazure23 [In Session] O

= cance. [ARSAENE connect

@ teradici

Ci PColP

6. Click Connect to connect to the selected desktop.

/" Ashortinterface delay is normal

When a session is first connected, it may take a few seconds before you can take control of the keyboard and mouse.

This is normal behavior.

/" Single-desktop users

If a user only has access to a single desktop, that desktop is automatically selected and the connection is initiated
immediately. These users are not presented with a desktop selection screen.

© 2021 Teradici
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Advanced Saved Connections

Advanced Saved Connections

Administrators can save more complex desktop connections with the PColP Client. The following
section outlines the connection scenarios that can be saved, and outlines the potential benefits of
doing so.

Saved Broker Address

This configuration enables you to create a saved connection where only the broker address is
saved. You need to enter your username when connecting to a remote host. Enter the host
address and name the connection, then click SAVE.

10.0.152.156 NEXT
My Test Desktop

= Er e

/" Pre-configured connections

This partial save feature enables administrators to pre-configure connection information as a saved connection and
bundle it with the client application. For example, administrators can save a connection with the FQDN of the PColP
Connection Manager preset and then distribute this information to their deployed clients. As a result of this users
would be able to skip past the initial domain screen and advance directly to their user authentication screen.

The administrator can find and distribute the connection info file located at SHOME/Library/Preferences/

com.teradici.PCoIP\ Client\ Connection\ Info.plist

© 2021 Teradici
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Multiple Desktops

Multiple Desktops

This configuration enables you to see and access a selection of desktop environments each time
you connect.

1. Enter the host address and name the connection

10.0.152.156 NEXT
My Test Desktop

= £ R

2. Enter and save the Username

© 2021 Teradici
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Multiple Desktops

Once you have done this each time you use this connection you will be presented with the list of

available desktops for that connection.
® O Teradici PColP Client

a TERVDILIND62 [Ready] Q a TERVDIW10P3 [In Session]

a vwazure23 [In Session] Q

= owce JESHENE connect

@ teradici

Ci PColP

© 2021 Teradici
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Connecting to Teradici PColP Remote Workstation Cards

Connecting to Teradici PColP Remote Workstation
Cards

You can connect to remote workstations with a Teradici PColP Remote Workstation Card and
PColP Host Software installed. Refer to System Requirements for supported versions.

Initial Workstation Configuration

Before you can connect to your remote workstation for the first time, a few things must be
configured on the host machine.

These configuration actions only need to be taken once on each remote workstation in your
system:

+ Record the MAC address of the PColP Remote Workstation Card

Before you install the PColP Remote Workstation Card in the workstation, record the MAC
address of the PColP Remote Workstation Card as this will will enable you to log into the card
to configure the settings. Type https://pcoip-host-0030040de898.mydomain where
0030040de898 is the MAC address of your PColP Remote Workstation Card and mydomain is
the local domain of your network. This step is important as the host driver function is disabled
by default, so the host software will not pick up information about the PColP Remote
Workstation Card, such as the MAC address. The MAC address enables you to connect to the
PColP Remote Workstation Card to view the IP address and enable the host driver function.

For more information on IP and MAC information relating to the PColP Remote Workstation
Card, see here.

+ Install PColP Remote Workstation Card Agent

To connect to a remote workstation with a PColP Remote Workstation Card using a PColP
Software Client, the Remote Workstation Card Agent must be installed.

+ Enable monitor emulation for the video ports on your remote workstation

If monitor emulation is not enabled, you may see blank gray screens when you connect from
the PColP Software Client.

© 2021 Teradici
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Connecting to a Remote Workstation Card

To enable monitor emulation, log in to the card’s Administrator Web Interface (AWI) and select
Enable Monitor Emulation on Video Port n from the Configuration > Monitor Emulation menu.
For more information, see the Tera? PColP Zero Client Firmware 4.x and Remote Workstation
Card Firmware 4.9 Administrators' Guide.

+ Disable temporal dithering

Temporal dithering causes blurriness, heavy packet loss, and high CPU usage on the PColP
Software Client machine. See Should | disable the dithering feature of my graphics card in a
remote workstation environment? (KB 15134-207) for more information.

+ Linux workstations: configure PColP Host Software to Start Automatically

To configure the PColP host software to start automatically, log into the workstation using a
PColP Zero Client or directly from a local mouse and keyboard, and modify the workstation
startup script to launch the PColP host software. For details, see Installing PColP Host
Software Binary RPM in the PColP® Host Software for Linux User Guide.

Connecting to a Remote Workstation Card

Once the remote workstation is properly configured, you can connect to it from the PColP
Software Client.

Workstation configuration is required before connecting

If you experience connection problems or degraded performance, make sure that the workstation is configured as
described in Initial Workstation Configuration.

Connecting to a Remote Workstation Card via a PColP Software Client

The direct connection from the PColP Software Client to the PColP Remote Workstation Card is
supported through the PColP Remote Workstaton Agent software which needs to be installed on
the workstation where the PColP Remote Workstation Card is installed. You must have a Remote
Workstation Card Agent installed to enable a connection to a Remote Workstation Card.

Both the NIC of the workstation and the Remote Workstation Card need to be connected to the
same network switch. When establishing a connection, the PColP Software Client should connect
to the IP or FQDN of the workstation, instead of the IP or FQDN of the PColP Remote Workstation
Card.

© 2021 Teradici
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Connecting to a PColP Remote Workstation Card through the command line

A Cloud Access Software Subscription

You need to have a valid Cloud Access Software Subscription to use the PColP Remote Workstation Card Agent.

2" Direct Connection to PColP Remote Workstation Cards

PColP brokering can now be used to connect to the Remote Workstation Card. You can still connect to a non-
brokered Remote Workstation Card by connecting to the FQDN of the workstation instead of the FQDN of the Remote
Workstation Card. This method of connection requires the Remote Workstation Card Agent to be installed on the
workstation

Connecting to a PColP Remote Workstation Card through the command line

You can have a direct connection to a PColP Remote Workstation card, from a PColP Software
Client, without requiring a PColP Remote Workstation Card agent installed on the host machine if
you connect via the command line by using the --hard-host option with the IP address of your
PColP Remote Workstation Card, for example:

/Applications/PCoIPClient.app/Contents/Mac0OS/PCoIPClient --hard-host 10.11.12.13

10.71.12.13 is the IP address of the PColP Remote Workstation Card.

Connecting to a remote workstation with a Teradici PColP Remote Workstation
Card installed:

1. Double-click the PColP Client desktop icon, alias, or program file (PColPClient) to launch the
application.
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PColP Remote Workstation Card Feature Compatibility

2. In the Host Address and Code box, enter the fully-qualified computer name or IP address of
the remote workstation or the address of the PColP broker, for example Cloud Access
Manager or a third-party broker.

3. Optional: In the Connection Name box, enter a name for your connection. This field accepts
any Unicode character.

2/’ The Connection Information can be saved

If you provide a connection name now, you will have the option of saving the connection after you are
authenticated. Saved connections can be quickly recalled later, without manually re-entering connection
information.

4. Click NEXT.

/" A short interface delay is normal

When a session is first connected, it may take a few seconds before you can take control of the keyboard and
mouse. This is normal behavior.

5. If your desktop is locked upon connection and requires you to enter Ctrl+Alt+Delete to log in,
select Connection > Send CTRL-ALT-DEL from the PColP Software Client menu bar.

PColP Remote Workstation Card Feature Compatibility

Not all features with the Software Client are fully supported when connecting to a PColP Remote
Workstation Card. The following section outlines these limitations against certain features.

Audio: PColP Remote Workstation Card uses a hardware based audio protocol which is not fully
supported on the Software Client.

Topology: Single display configuration will work. There may be disruptions in the forms of black
bars or scroll bars on the client if the PColP Remote Workstation Card does not support the
display configuration on the client. The worst instance of this disruption will occur for some client
configurations that don't work with the hard host configuration.

USB: Connecting USB devices to the PColP Remote Workstation Card is not supported.

Performance: Updated to support PColP Ultra are not applicable to the RWC.
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Connecting Remotely using NAT or VPN

Connecting Remotely using NAT or VPN

The same principles that apply for PColP Zero Clients apply to PColP Software Clients when
connecting to multiple hosts through a WAN. Connections from a PColP Software Client to a
Remote Workstation Card across a WAN will require a VPN or NAT setup with enterprise level
NATing devices. For information on how to connect a PColP Software Client to a Remote
Workstation Card installed in a Windows host computer, see here.
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Connecting to a USB Device

Connecting to a USB Device

Remote Windows hosts using the PColP Standard Agent or the PColP Graphics Agent can use
USB devices that are attached to the client. When you connect a local USB device to your remote

host it will be disabled on the client machine.

USB device connections do not persist across multiple PColP sessions. You must connect your
USB device each time you connect.

2" PColP Agent needs to be configured to enable USB redirection

The USB menu will only show up if the PColP Agent has been configured to enable USB redirection and a USB device
has been detected by the PColP Client.

/" One-time PColP Software Client for macOS login

The first time you connect after a Mac installation, you must enter a Mac administrator user name and password. You
only need to do this when you install a new client.

/" ePadLink Signature Pad and some Wacom tablets are connected via local termination

If you are using an ePadLink Signature Pad and certain Wacom tablets they can be connected via local termination.
You do not need to carry out any other steps to establish this connection. For information on which Wacom tablets
are locally terminated, see Wacom Tablets.

/" NoMachine USB Driver Compatibility

PColP Clients are not compatible with NoMachine and No Machine USB drivers. For information on how to uninstall
NoMachine USB drivers, see here.

The following section outlines how to connect a USB device:

1. Attach the USB device you want to connect.

2. Select Connection > USB Devices from the PColP Software Client menu.
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Disconnecting a USB Device

A list of USB devices connected to your client machine appears. Integrated USB devices, such
as built-in cameras on laptops, will appear in this list along with devices you have plugged in

yourself.

Some devices will identify themselves only as USB Device.

3. Click Connect beside the USB device you want to use.

[ ] @) USB Devices
DEVICES
v3.5.0.8 Connect
Bluetooth USB Host Controller Unauthorized

Show Human Interface Devices. Devices that are auto-forwarded are not affected by this checkbox.

ﬁ Connecting to Human Interface Devices
Most Human Interface Devices (HIDs), such as keyboards and mice, are automatically handled by the PColP Software
Client and don't appear on in this list even if they use a USB connection.

If you need to connect a Human Interface Device that can't be locally processed, like a 3D mouse or a Wacom tablet,
enable the Show Human Interface Devices checkbox to reveal the device in the USB device list and click its Connect

button.

You may also have to complete additional configuration steps or install drivers on the host machine.

Disconnecting a USB Device

1. Select Connection > USB Devices from the PColP Software Client menu.
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USB Auto-Forward for Non-HID Devices

2. Click Disconnect beside the USB device you want to disconnect.

[} USB Devices X

DEVICES

ADATA USB Flash Drive Disconnect

[] show Human Interface Devices. Devices that are auto-forwarded are not affected by this checkbox.

USB Auto-Forward for Non-HID Devices

A HID is a device class definition that enables a generic USB driver to support devices such as
keyboards, mice, tablets, controllers, etc. Non-HID devices primarily run on the PS/2 port transport.
Automatic bridging enables you to auto bridge all non-HID USB devices by using the usb-auto-
forward command line parameter.

USB Vendor ID/Product ID Auto-Forward

You can automatically forward up to 20 USB devices to the host at the start of the session by
calling the PColP client executable with vidpid-auto-forward and the required VID/PID pairs.
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USB Vendor ID/Product ID Auto-Forward

2" VID/PID Pairs

You can locate the VID/PID pairs from the PColP Client logs which are placed in ~/Library/Logs/Teradici/
PCoIPClient. When getting the VID/PID pairs from the log you need to strip 0x from the IDs, and use the rest of the
ID when running the vidpid-auto-forward command. As outlined in the following example:

2040-12-12T20:36:46.117Z ebf9e9e9e-866f-1038-test-ac87a3007abc LVL:2 RC: 0
MGMT_USB :Device 0x00010001 VID=0x**18a5**PID=0x**0302**
2040-12-12T720:36:46.117Z eBf9e9e9e-866f-1038-test-ac87a3007abc LVL:2 RC: 0
MGMT_USB :Device 0x00010001 Name=TEST Serial=012345ABCDE pp=000222222

The VID/PID pair in this scenario would be 18a5,0302.

USB VID/PID Auto-forwarding workflow

Unplug all USB Launch the PCoIP Plugin the required Close the PColP Locate the ogrie fo Run the vidpid-auto-
Devices Client usB Client device forward command

Devices that are auto-forwarded will appear in the USB Devices dialog box, enabling users to

connect or disconnect them from the host. The PColP Client application is located at
PColPClient.app/Contents/MacOS. The following is an example of how this command would look
with the VID/PID values:

./PCoIPClient -vidpid-auto-forward "1234,5678 abcd,efgh"”

The following rules apply to VID and PID values:

VID/PID values are comma-separated: xxx, yyy

VID/PID pairs are space-separated: aaa, bbb ccc, ddd

VID/PID pairs with invalid values will be discarded. Discarded rules appear in the event log.

+ Up to 20 devices will be passed; if more than 20 are attempted, the first 20 will be accepted
and rest ignored. Ignored rules appear in the event log.
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Configuring Wacom Tablets

Configuring Wacom Tablets

This section outlines how to configure your Wacom tablet through the PColP Client session. There
are two available features within the PColP Client that can be used to configure the monitor

display and orientation.

Tablet Monitor

The Tablet Monitor feature enables you to select the monitor you want to use with your Wacom
tablet. You can change between using a pen or mouse and select the orientation position.

To configure Tablet Monitor settings:

1. Select View from the in-session options bar.
Check the Tablet Monitor option.
Open Wacom Tablet Properties from the Wacom Desktop Center.

Select your device, tool and application.

a H w0 N

Select your screen area from the dropdown menu.
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Tablet Monitor

Teradici PColP Client Connection = View

Leave Fullscreen Ctrl+Alt+Enter
Show Fullscreen One Monitor

Minimize Client Ctrl+Alt+M
Tablet Monitor

Tablet Orientation Left-handed

Recycle Bin

@ Wacom Tablet Properties

Device:
Intuos Pro M

b | S

Functions Pro Pen 2

Application:

All

Pen Eraser Mapping

Orientation: ExpressKeys Left

Mode

@ Pen (O Mouse

Screen Area: Monitor 1

Full
Portion...

Monitor 2

Tablet Area: Full

Use Windows Ink

Options...
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Tablet Orientation Left-handed

Tablet Orientation Left-handed

The left-handed orientation configures the tablet for a left-handed orientation. Select ExpressKeys
Right for a left-handed orientation, and ExpressKeys Left for a right-handed orientation. Rotate the
tablet to the desired orientation.

To configure Tablet Orientation:

1. Select View from the in-session options bar.
Check the Tablet Orientation Left-handed option.
Open Wacom Tablet Properties from the Wacom Desktop Center.

Select your device, tool and application.

a > W

Select your orientation from the dropdown menu.
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Tablet Orientation Left-handed

Teradici PColP Client Connection = View
Leave Fullscreen Ctrl+Alt+Enter
Show Fullscreen One Monitor
Minimize Client Ctrl+Alt+M
Tablet Monitor

v Tablet Orientation Left-handed

Recycle Bin

@ Wacom Tablet Properties

Device:
Intuos Pro M

b | S

Functions Pro Pen 2

Application: ‘
All

Pen Eraser Mapping

Orientation: ExpressKeys Right
ExpressKeys Left

Mode

(® Pen

ExpressKeys Bottom

Screen Area: Monitor 1

[] Force Proportions

Tablet Area: Full

Use Windows Ink
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Using Saved Connections

Using Saved Connections

Once you have saved a connection, you can use it to reconnect easily.

To reconnect using your saved connection:

1. Click the button for the saved connection. The button label displays the connection name you

assigned when you configured the connection.

= My Win Desktop = My Windows Workstation Card

a NEW CONNECTION

2. To see the connection address, hover your mouse over the saved connection. Hovering over a

saved virtual desktop will also show the desktop name.

= My Win Desktop = My Windows Workstation Card

My Win Desktop
URL: desktop.teradici.com

E NEW CONNECTION
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To reconnect using your saved connection:

3. To edit or delete a saved connection, click the configure button on the right, and then select

the desired option from the popup menu.

B My Windows Workstation Card O

Delete

E NEW CONNECTION

4. If you have saved multiple connections, click the desired one to reconnect. If you have multiple
saved connections use the search bar to locate the connection and scroll down to find it.

a My Linux Desktop ﬁ a My Linux Workstation Card O

= My Win Desktop < n My Windows Workstation Card &b

E NEW CONNECTION

5. Any time you wish to connect to a new workstation, just click NEW CONNECTION to return to

the main screen, and then enter the connection details.
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Filtering through your saved connections

Filtering through your saved connections

You can use the search bar to now filter saved connections based on there connection names.

= My Linux Desktop O a My Linux Workstation Card Q

E NEW CONNECTION
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Disconnecting a Session

Disconnecting a Session

To disconnect a PColP session, select the Connection > Disconnect menu option.

@ Teradici PColP Client View
O O A Client

Disconnect X F12

Recycle Bin

6 Quickly Disconnect from a session

To quickly disconnect from a session, press CTRL+Option+F12

Quitting the PColP Client application will also disconnect the current session.

Session Reconnection

If a network interruption is detected, the PColP session enters a reconnecting phase. In this phase
the client will show you the network reconnecting dialog which indicates that there is a network
issue and that the client is trying to reconnect and re-establish the PColP session. You can click
disconnect to cancel the attempted reconnect and disconnect the session completely. If the
reconnection is successful, the notification dialog will disappear and the session will be restored, if
not, the session will be disconnected completely.
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Changing the PColP Software Client Window Mode

Changing the PColP Software Client Window Mode

You can use the PColP Software Client in full-screen or windowed mode. Full-screen mode is
recommended in most cases.

Activating Full Screen Modes

The PColP Software Client provides two full-screen modes: one monitor and all monitors.
To switch from windowed mode to full-screen mode:

+ To use one full-screen display, select View > Show Fullscreen One Monitor.

All open windows and applications will be moved to a single full-screen display. This is
equivalent to disconnecting all but one monitor from a physical host.

- To use all available full-screen displays, select View > Show Fullscreen All Monitors.

This mode shows full-screen displays on all client monitors.

6 Keyboard shortcut

You can also enter full-screen mode by pressing Ctrl+Option+Return while in windowed mode. The shortcut will
activate whichever full-screen mode was used last, or all monitors if no previous selection was made.

To switch from Fullscreen One Monitor to Fullscreen All Monitors mode:

1. Reveal the menu bar by moving the mouse cursor to the top of a client display.

2. Select View > Show Fullscreen All Monitors.
To switch from Fullscreen All Monitors to Fullscreen One Monitor mode:

1. Reveal the menu bar by moving the mouse cursor to the top of a client display.

2. Select View > Show Fullscreen One Monitor.
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Miminizing the PColP Software Client from a Full-screen Mode

0 Persistent Display Topology

Depending on the display topology mode you have selected, for example Fullscreen One Monitor, if you disconnect
and then reconnect to the session, it will maintain that same mode upon reconnection. The state and mode will be

preserved.

Miminizing the PColP Software Client from a Full-screen Mode

To minimize a software client in full-screen mode:
1. Reveal the menu bar by moving the mouse cursor to the top of any display.
2. Select View > Minimize Client.
6 Keyboard shortcut

You can also minimize the client by pressing Ctrl+Option+m while in any full-screen mode.

Activating Windowed Mode

To switch from full-screen mode to windowed mode:

1. Reveal the menu bar by moving the mouse cursor to the top of any display.

2. Select View > Leave Fullscreen.

6 Keyboard shortcut

You can also enter windowed mode by pressing Ctrl+Option+Return while in any full-screen mode.
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Detect Monitors

Detect Monitors

The detect monitors feature enables you to add and remove displays from the desktop through the

PColP Client while in an active session.
Adding a Display
The following steps outline how to add a display to your desktop through the PColP Client:

1. Connect a new monitor to the client.
2. From the desktop, click View.
3. Click Detect Monitors.

4. Select the monitor you want to add.
The displays on the remote desktop will be extended to include the new monitor.
Removing a Display
The following steps outline how to remove a display from your desktop.

1. Disconnect a monitor from the client.
2. From the desktop, click View.

3. Click Detect Monitors.

You will no longer see the monitor that you have disconnected from the client.
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Enhanced Audio and Video Synchronization

Enhanced Audio and Video Synchronization

Enhanced Audio and Video Synchronization provides improved full-screen video playback,
reducing the difference in delays between the audio and video channels and smoothing frame
playback on the client. This improves lip sync and reduces video frame drops for video playback.

This feature introduces a small lag in user interaction responsiveness when enabled. Using
enhanced audio and video synchronization will reduce the maximum frame rate.

Enhanced A/V Sync is enabled on a per-display basis, so you can dedicate individual displays to
playback without impacting responsiveness on the others.

To use enhanced A/V Sync:

1. If you are in full-screen mode, reveal the menu bar on the display you want to enhance by

moving the mouse cursor to the top of the screen.

2. On the display you want to enhance select View>Enhanced A/V Sync to toggle the enhanced
sync mode.
6 Persistent Display Topology

The Enhanced Audio and Video Synchronization feature is persistent across sessions from the same client, provided

that the display topology has not changed.
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Sending a Ctrl-Alt-Del Command

Sending a Ctrl-Alt-Del Command

To send the Ctrl-Alt-Del keyboard command to a remote workstation, select the Connection >
Send CTRL-ALT-DEL menu option.

@ Teradici PColP Client [el st View
O O

Recycle Bin
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Changing the Language

Changing the Language

In addition to English, the PColP Software Client also supports these languages: Chinese
(Simplified), French, German, Italian, Japanese, Korean, Portuguese (Brazil), Portuguese (Europe),

Russian, Spanish, and Turkish. During installation, you can select one of the supported languages.

To change the language after installation:

+ In System Preferences > Language & Region > Advanced > General tab, select another
language in the Format language list.

To change the language on the command line

Alternatively, the language can be set with the locale parameter on the command line:
pcoip-client --locale <locale-code>

The following table lists the available language translations and codes:

Language Code

German de
Spanish es
French fr
[talian it
Japanese ja
Korean ko
Portuguese (EU) pt
Portuguese (Brazil) pt_BR
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Language Code

Russian ru
Turkish tr
Chinese (Simplified) zh_CN

Chinese (Traditional) zh_ TW
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System Precedence

System Precedence

The following section outlines the scope precedence commands between the System Scope and
User Scope. If you are updating individual user settings then the user scope locations and
parameters can be followed. Due to this order of precedence where by the system scope setting
takes precedence over the user scope setting, a change in the user settings may not take effect if
the system scope setting has been updated.

System Scope

The .plist files are located in /Library/Preferences/. The following commands detail the read,

delete and write sudo functions:

sudo defaults read "com.teradici.Teradici PCoIP Client.plist" <Key>
sudo defaults delete "com.teradici.Teradici PCoIP Client.plist" <Key>

sudo defaults write "com.teradici.Teradici PCoIP Client.plist" <Key> <value>

If sudo is not used in the command, it will automatically go to the user settings.

User Scope

Within the user scope the .plist files are located in ~/Library/Preferences/. The following
commands detail the read, delete and write functions:

defaults read "com.teradici.Teradici PCoIP Client.plist" <Key>
defaults "com.teradici.Teradici PCoIP Client.plist" <Key>

defaults write "com.teradici.Teradici PCoIP Client.plist" <Key> <value>

If sudo is used, it will go to the system settings.
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System Precedence

2" Re-boot Requirement

The macOS machine may require a re-boot for the system configuration to take effect.
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PColP Client Parameters

PColP Client Parameters

The following table outlines command line parameters that are available to use and customize:

Short

Long

Default Description

2

-V

-u

W

help

version

username

password

domain

connection-broker

log-level

windowed

fullscreen

security-mode

locale

disable-usb

hard-host

quit-after-disconnect

usb-auto-forward

vidpid-auto-forward

© 2021 Teradici

Display help message. Set to false by default.

Print version information. Set to false by default.

Username sent to Connection Broker.

Password sent to Connection Broker.

Domain sent to Connection Broker.

Connection broker URL.

Unset force log level (will override config/registry)

False run inside a window.

False run in full-screen mode. The default is to run in windowed mode.

Security mode.

Set locale.

Disable USB.

Hard host URL. This option is ignored if connection-broker is provided

Do no re-enter the pre-session after leaving the in-session.

Auto-forward all non-HID devices.

String of VID, PID hex values separated by spaces.
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Launching PColP Software Client with a URI

Default Description

remap-cmd-to-ctrl Enables the macOS [ cMD | key to map to the Windows Super key on the
host. This parameter has some limitations, if the [CMD + "randomkey" | is
a hotkey for the local OS then the PColP Client will capture the [CMD  key
and map that to Super (or Windows key) but the macOS Client will
suppress the | "randomkey" | key from the application.

vidpid-black-1list Blocks specific VID,PIDs from autoforward regardless of whether the
usb-auto-forward parameter or the USB dialog is used.

You need to ensure that the parameters are properly formatted. When using the short form of the
parameter you must use -X, where X is the short forms of the parameter. Long forms of the
parameters must be formatted using --YYY-YYYY, where YYY-YYYY is the long form of the
parameter. If the parameters are not correct the client will close.

Launching PColP Software Client with a URI

It is possible to launch the PColP Software Client with a URI. The Teradici URI uses JSON Web
Tokens (JWT). For more information on the use of JWT, see here. The URI is defined as the
following:

pcoip://[broker]/connect[?data={jwt}]

When additional parameters are passed through the encoded JWT a session can be launched:

Description Optional vs
Required
pcoip:// Scheme registered to operating system so that PColP Client can be Required
launched
broker Broker through which a pcoip session is supposed to be brokered through Optional
/ Connecting to a PColP Client with the parameters defined in "?data" Required
connect
?data Query parameter to store a jwt encoded user credentials Optional
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Launching PColP Software Client with a URI

The table below details supported optional JWT payload claims:

Claim Description

usr Username

dom Domain

vm Virtual machine/resource name
sid Broker JSESSIONID

Below is an example of a JWT payload:

{
“usr": "username",
"dom": "mydomain.com",
"vm": "mydesktopname"
}

The following is an example of a connect command:

pcoip-client pcoip://fake.broker.com/connect?

data=eyJhbGci0iJIUzITNiIsInR5cCI6IkpXVCJ9.eyJ1c3I1101J1¢c2VybmFtZSIsImRvbSI6Im15ZGotY
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Custom Logo in Pre-Session

Custom Logo in Pre-Session

The PColP Software Client can be configured to place a custom logo beside the PColP logo at the
bottom right corner of the PColP Software Client login dialog. For best results, the logo should be a
.png file with a transparent background, and ideally should be 245x100 or smaller. The image must

be named customlogo.png.

+ macOS location: ~/Library/Preferences/Teradici/PColPClient/
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HID Local Termination Blacklist

HID Local Termination Blacklist

Local Termination of Wacom tablets provides the best user experience in networks with high
latency, however some features of the tablet may not be fully supported with local termination. A
HID local termination blacklist has been added to override the preferred local termination mode.

Devices on the blacklist would be bridged to the remote desktop. To enable the HID local
termination blacklist, add the following setting to com.teradici.Teradici PColP Client.plist. The

vendor and product IDs are separated by a comma and multiple devices are separated by a space.

localtermination_black_list="vid, pid vid2,pid2"

Troubleshooting HID Local Termination Blacklist

The following lines should appear in the PColP Agent log if a device is using HID local termination:

pcoip server log: 'LVL:2 RC: © MGMT_KMP :Client added HoIP device (id:0x000a0005)
with vendor id=0x@56a, product id=0x6391"

pcoip client log: 'LVL:2 RC: © MGMT_USB :HoIP supported device detected (Vid:
0x056a, Pid: 0x0391), using HoIP protocol for local termination'
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PColP Software Client Security Modes

PColP Software Client Security Modes

The PColP Software Client uses certificates to verify the identity of the host to which it connects.
The security mode is configured by the security_mode setting in the Teradici PColP Client
configuration file, which is described next. Three security mode options are available:

+ security_mode=0: verification is not required A red, unlocked padlock icon appears on the
client login screen.

- security_mode=1: warn but allow (default) If a certificate cannot be verified, an 'untrusted
server' warning displays and a red, unlocked padlock icon appears on the client login screen.

Users still have the option of connecting.
This mode is used if security_mode is not set in the configuration file.

- security_mode=2: full verification is required Users cannot connect unless a certificate can be

verified.

2’ PColP sessions are always encrypted

Your PColP session is still encrypted and secure if you connect with security mode 0 or 1. The red padlock icon
indicates that the certificate presented by the host is not signed by a trusted certificate authority in the client’s

certificate store, not that the session is insecure.

Setting the Security Mode
Use the following procedure to set the PColP Software Client's security mode.
To set the security mode for the PColP Software Client:

1. Close the PColP Software Client.

2. Open a terminal window and type the following command at the command line:

sudo defaults write "com.teradici.Teradici PCoIP Client.plist" security_mode

<value>

where value is your desired security option (0, 1, or 2).
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Setting the Security Mode

2" Reboot May Be Required

After running the above command, you may be required to reboot your machine for this change to take effect.
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Installing the Internal Root CA Certificate in a PColP Client

Installing the Internal Root CA Certificate in a PColP
Client

Your root CA certificate must be installed in any PColP client that will be used to connect to the
PColP Agent.

Installing Root CA Certificates in the PColP Software Client for macOS

6 Important: Root CA Certificate must have a .crt extension

You must change the root CA certificate's extension from . pemto . crt before installing it on a PColP Software
Client.

In macOS, certificates are stored in the Keychain Access application.

To import your root CA certificate in the PColP Software Client for macOS:

1.

N o o > W

Copy your root CA certificate file (*.crt) to the Mac client desktop.

Double-click Applications > Utilities Keychain Access.app to open Keychain Access.
Select File > Import Items.

Navigate to the desktop and then select your root CA certificate.

In the Destination Keychain drop-down menu, select System, and then click Open.

If prompted, enter your Keychain Access password and then click Modify Keychain.

At the next screen, click Always Trust when asked whether you want your computer to trust
certificates signed by this certificate.

If prompted, enter your Keychain Access password and then click Update Settings.

After the certificate installs successfully, it appears in the System > Certificates list.
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Contacting Support

Contacting Support

If you encounter problems installing or using Teradici technology, you can:

+ Check for updated release notes, which may address the issue you are experiencing. Release
notes are published on Teradici Support.

+ Browse the Teradici Knowledge Base.

+ Submit a support ticket.
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The Teradici Community Forum

The Teradici Community Forum

The PColP Community Forum allows users to have conversations with other IT professionals to
learn how they resolved issues, find answers to common questions, have peer group discussions
on various topics, and access the Teradici PColP Technical Support Service team. Teradici staff
are heavily involved in the forums.

To join the Teradici community, visit the Teradici Community Forum.
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Creating a Technical Support File

Creating a Technical Support File

Teradici may request a support file from your system in order to troubleshoot and diagnose PColP
Issues.

The support file is a tar.gz archive containing PColP Software Client for macOS logs and other
diagnostic data that can help support diagnose your problem.

To create a support file:

1. Open a terminal window.

2. Launch the support bundler:

username$ /Applications/PCoIPClient.app/Contents/Resources/pcoip-client-support-
bundler

The file will be created and placed in the user's home directory.
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Mapping Function Keys

You can enable Function keys on the PColP Software Client for macOS by going to Apple>System
Preferences>Keyboard and selecting the function keys you wish to use as standard keys. When
the system is configured to not use function keys the PColP Software Client does not get the
function key codes from the system when the keys are pressed. In this instance the function keys
are usd for other system features such as turning the volume up and down.
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Checking the PColP Software Client Software
Release

The PColP Software Client pre-session window contains an About button in the lower left of the
window. Click this button and then select About from the popup menu to display the PColP
Software Client software release version.

® O Teradici PColP Client

= TERVDILIND62 [Ready] Q n TERVDIW10P3 [In Session]

a vwazure23 [In Session] Q

E CANCEL m CONNECT

@ teradici

i PColP

From either client, you can also select the Teradici PColP Client > About Teradici PColP Client
menu to display the software release version from within a PColP session.
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€ E TR L connection  View
About Teradici PColP Client

Services >

Hide Teradici PColP Client 3H
Hide Others X #¥H
Show All

Quit Teradici PColP Client #Q

2" About menu item only appears when the client is in session

The About Teradici PColP Client menu item only appears when the client is in session. The menu item is not available
from the pre-session GUI.
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Troubleshooting Your PColP Software Client

This section demonstrates using PColP Software Client log files to troubleshoot problems you
may encounter with your PColP Software Client.

PColP Software Client logs are text (.txt) files that contain system and session information about
your connection. They are useful for troubleshooting problems. A new log file is created each time
you use a PColP Software Client to initiate a PColP session.

Client logs are placed in ~/Library/Logs/Teradici/PCoIPClient .

If you experience a problem, recreate the issue, generate a support bundle and contact Teradici
Support. You can also check the Teradici PColP Community Forum for troubleshooting
information about this product.
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Session Log IDs

Session Log IDs

The PColP Software Client creates a unigue session ID when a new session is established, and
distributes that ID to all components in the system. When PColP components generate log
messages, they are prefixed by this unique session ID, allowing administrators and support to
easily group events by session across multiple components:

yyyy-mm-ddThh:mm:ss. ffffffZ XXXXXXXX=XXXX=XXXX=XXXX~XXXXXXXXXXXX > ..
For example:
2015-11-06T08:01:18.688879Z 4208fb66-€22a-11d1-a7d7-00a0c982c00d > ..

Log messages that do not pertain to a specific session will show a string of zeroes in place of the
session log ID number.
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Setting Log Levels

Setting Log Levels

You can set log levels to determine the level of details provided in the log. Log levels range from 0
to 3, where 0 provides the least information and 3 provides the most information.

To set log levels:

+ open /Applications/PCoIPClient.app --args -1 x where 1 islowercasel and x is
desired the log level (1, 2, or 3).
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Locating PColP Software Client for macOS Log
Files

On a Mac computer, PColP Software Client log files are located within the user's Home Library
folder, which is hidden by default. The recommended way to access Home Library files is to use

the macOS Console.
You can also display log files in a macOS terminal window.
To display log files using the macOS Console:

1. To open the Console, go to the Applications > Utilities folder, and then double-click Console.

2. Inthe FILES section of the Log List pane on the left, navigate to the following folder: ~/
Library/Logs/Teradici/PCoIPClient

3. Select the desired log file to view its contents in the main pane.

4. To copy the contents:
+ Click anywhere in the log contents, and then select Edit > Select All.
+ Select Edit > Copy.

+ Paste the contents into an email or text file.
To display log files in a macOS terminal window:
1. To open a terminal window, go to the Applications > Utilities folder, and then double-click

Terminal.

2. Navigate to the PColP Software Client log folder by typing the following command at the
command line prompt:

cd ~/Library/Logs/Teradici/PCoIPClient
3. Type 1s to display the list of log files.
4. To view the contents of a log file, use any macOS command-line editor to open it.

5. To open a terminal window, go to the Applications > Utilities folder, and then double-click

Terminal.
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6. Navigate to the PColP Software Client log folder by typing the following command at the
command line prompt:

cd ~/Library/Logs/Teradici/PCoIPClient
7. Type 1s todisplay the list of log files.

8. To view the contents of a log file, use any macOS command-line editor to open it.
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Reconnecting a PColP Session

If a network interruption is detected, the PColP session enters a reconnecting phase. In this phase
the client will show you the network reconnecting dialog which indicates that there is a network
issue and that the client is trying to reconnect and re-establish the PColP session. You can click
disconnect to cancel the attempted reconnect and disconnect the session completely. If the
reconnection is successful, the notification dialog will disappear and the session will be restored, if
not, the session will be disconnected completely.
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Microphone Access on MacOS Catalina 10.15

On MacOS Catalina 10.15 you are required to enable access to the microphone before audio input
works. The following steps outline how to enable this access:

1. Go to System Preferences.

2. Click Security & Privacy.

3. Click on the Privacy control panel.

4. From the left side menu click Microphone.

5

. Ensure that the PColPClient application has a checkmark. This indicates that the application is
allowed to use the microphone.

2" Unlocking Control Panel

To make a change in the control panel you need to ensure that the panel is unlocked by clicking the lock icon on the
control panel.
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USB Device Pressure Sensitivity

The PColP Software Client for macOS may encounter issues with Wacom pressure sensitivity.
This is as a USB handling restriction on macOS Catalina. It occurs when you want to load the USB
Kernel Extension at session start up. The following workaround can be used on OSX Catalina to
enable kext (Kernel extension) specifically:

1. Run the following command:
sudo kextload /Applications/PCoIPClient.app/Contents/Mac0S/usb-mediator.kext
2. You will receive the following error:

/Applications/PCoIPClient.app/Contents/Mac0S/usb-mediator.kext failed to
load - (libkern/kext) system policy prevents loading; check the system/
kernel logs for errors or try kextutil(8)"

3. Open your System Preferences.

4. Select Security and Privacy.

5. Select the General tab and you will be asked to approve the kext from Teradici.

6. Approve the kext and the device will be visible and available as a connection in the client.
ﬁ Wacom Tablet Connection
Another common problem that user's are running into that causes pressure sensitivity is they are not connecting the

Wacom tablet to the remote workstation. It is important to understand that even if you are using a Wacom table that
supports local termination, you need to connect the Wacom table to the remote workstation.
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